SPARC Support Phone Number Outage
Incident Report for SPARC Media Hub
Resolved
The phone system has been restored. We apologies for any inconvenience.
Posted Nov 22, 2022 - 07:48 EST
Investigating
We're currently experiencing a general phone system outage. This only affects our general support line and not the emergency number. Our 24 hour emergency number remains operational. Should you require support, please continue to email our general support inbox info@sparcmediahub.com until an update becomes available.

We apologize for the inconvenience this may cause.
Posted Nov 21, 2022 - 17:25 EST
This incident affected: Main Application.